Capital letter issue in the Term Base
Autor vlákna: Zeki Güler

Zeki Güler  Identity Verified
Turecko
Local time: 17:40
Člen (2012)
angličtina -> turečtina
+ ...
Aug 20, 2015

Hi,

I want to enter just once, and to see it works in all cases above, regardless of whether there are any capital letters or not. In other words, I dont want to enter the same term several times to the TB, by changing the letters to the capital and vice versa. For example:
Xyz > Xyz
xyz > xyz
XYZ > XYZ
xYZ > xYZ

How can I do it?

Thanks,


 

Stepan Konev  Identity Verified
Ruská federace
Local time: 17:40
angličtina -> ruština
New term defaults Aug 20, 2015

You can disable the case sensitive mode for all new entries:
Select your TB => Properties => New term defaults => Select source or target language => Select 'No' for 'Case sensitivity'.

However the result (target) from TB will always be the same case (as you typed it when adding term).
E.g. if you add Xyz > Xyz, you will have
xyz > Xyz
XYZ > Xyz
xYZ > Xyz

This is because you may have more than one word in a TB entry with different number o
... See more
You can disable the case sensitive mode for all new entries:
Select your TB => Properties => New term defaults => Select source or target language => Select 'No' for 'Case sensitivity'.

However the result (target) from TB will always be the same case (as you typed it when adding term).
E.g. if you add Xyz > Xyz, you will have
xyz > Xyz
XYZ > Xyz
xYZ > Xyz

This is because you may have more than one word in a TB entry with different number of words in source and target.
For example, three English words 'Permit to Work' become two hyphen-separated words in Russian: 'наряд-допуск'.
In this case, memoQ just cannot identify how to behave with capitalization.
Collapse


Michel_Sevilla
 

Zeki Güler  Identity Verified
Turecko
Local time: 17:40
Člen (2012)
angličtina -> turečtina
+ ...
AUTOR TÉMATU
How about %100 case sensitivity ? Aug 20, 2015

Is there a way to enter just one term, but get various versions of it depending on what I type (with capital letters) ?

I mean I want to enter just xyz>xyz, but when I type the same word with a capital letter, I want to view its capital version like these :
e.g. xyz > xyz, Xyz> Xyz , XYZ>XYZ ...etc.

Does setting case sensivity to %100 provide me with these results ?


 

Stepan Konev  Identity Verified
Ruská federace
Local time: 17:40
angličtina -> ruština
Nope Aug 21, 2015

No, you can't. I've explained above why this is not possible. memoQ (like any other CAT tool) is not a crystal ball to forsee which words need capitalization.

The only way to do so is adding all capitalization variants as synonyms. But if you do so each time, you may have your TB clogged with messy variants.
Use shift+F3 for capitalization as a possible solution.

[Edited at 2015-08-21 07:56 GMT]


 

Châu Nguyễn  Identity Verified
Vietnam
Local time: 21:40
Člen (2012)
angličtina -> vietnamština
+ ...
I did not manage to do it Aug 23, 2015

Stepan Konev wrote:

You can disable the case sensitive mode for all new entries:
Select your TB => Properties => New term defaults => Select source or target language => Select 'No' for 'Case sensitivity'.

However the result (target) from TB will always be the same case (as you typed it when adding term).
E.g. if you add Xyz > Xyz, you will have
xyz > Xyz
XYZ > Xyz
xYZ > Xyz

This is because you may have more than one word in a TB entry with different number of words in source and target.
For example, three English words 'Permit to Work' become two hyphen-separated words in Russian: 'наряд-допуск'.
In this case, memoQ just cannot identify how to behave with capitalization.


I set New term defaults to No for both languages. I entered the term as xyz > abc. And MemoQ still did not suggest the term when I typed Abc, I have to type abc before MemoQ gives suggestion. This is a minor but really frustrating issue. I don't want to clog my TB with variants of different cases of the same term.


 

Stepan Konev  Identity Verified
Ruská federace
Local time: 17:40
angličtina -> ruština
If you entered xyz > abc... Aug 23, 2015

...what term do you expect from memoQ TB when typing 'Abc'?

It works so that when you have Xyz or xYz or xyZ or XYz or XyZ... in the source part, you will always have 'abc' as a result from TB.

memoQ suggests you 'abc' (which is a target term) when you type 'abc' and does not suggest 'abc' when you type 'Abc' _becuase_, in this case, it uses Autosuggest mechanism, but not the Termbase.

If you want to disable the Autosuggest case-sen'ty, go to Translatio
... See more
...what term do you expect from memoQ TB when typing 'Abc'?

It works so that when you have Xyz or xYz or xyZ or XYz or XyZ... in the source part, you will always have 'abc' as a result from TB.

memoQ suggests you 'abc' (which is a target term) when you type 'abc' and does not suggest 'abc' when you type 'Abc' _becuase_, in this case, it uses Autosuggest mechanism, but not the Termbase.

If you want to disable the Autosuggest case-sen'ty, go to Translation -> Predictive typing... -> Uncheck Suggestions are case-sensitive.

[Edited at 2015-08-23 22:56 GMT]
Collapse


Jonathan von Zelowitz
RobertRicker
 

Haralabos Papatheodorou  Identity Verified
Řecko
Local time: 17:40
Člen (2008)
angličtina -> řečtina
+ ...
Disabling capitalisation of terms Apr 25, 2017

To ignore case sensitivity, you need to set the case sensitivity attribute of each and every term in the term base to No. Go to Tools > Resource Console, and select Term bases, then select the term base you want to edit and click Edit. After this select all terms by pressing Ctrl+Shift+A. At the bottom of the screen you see the two selected languages. Under the language where you want to ignore case sensitivity select Case sensitivity and select No. A dialog appears, click Yes. Now your terms wi... See more
To ignore case sensitivity, you need to set the case sensitivity attribute of each and every term in the term base to No. Go to Tools > Resource Console, and select Term bases, then select the term base you want to edit and click Edit. After this select all terms by pressing Ctrl+Shift+A. At the bottom of the screen you see the two selected languages. Under the language where you want to ignore case sensitivity select Case sensitivity and select No. A dialog appears, click Yes. Now your terms will be recognised regardless of their case.

(Source: http://kb.memoq.com/article/AA-00425/0/Disabling-capitalisation-of-terms.html)
Collapse


 

Anthony Veretyuk
Ruská federace
Local time: 21:40
angličtina -> ruština
+ ...
Predictive case sentitivity Feb 23, 2018

Stepan Konev wrote:
If you want to disable the Autosuggest case-sen'ty, go to Translation -> Predictive typing... -> Uncheck Suggestions are case-sensitive.

[Edited at 2015-08-23 22:56 GMT]


Степан, огромное спасибо. Перерыл я МемоQ вдоль и поперек, но эта функция почему-то постоянно выпадала из поля зрения. Благодаря вам, я наконец-то решил эту проблему! Удачи вам!

Dear, Stepan! I would like to thank you for your help! I have been looking for this solution for about 2 years and suddenly I have found it! And that happened thanks to you! Good luck to you!


 

Stepan Konev  Identity Verified
Ruská federace
Local time: 17:40
angličtina -> ruština
Funnily Apr 5

I have been not using memoQ for so long time now that I forgot how to fix this 'bug'.
It took me two days to find this thread. Thank you Stepan! Hahaha


 

Tomasz Swolany
Polsko
Local time: 16:40
angličtina -> polština
+ ...
THX Jun 3

Thank you, it helped me too!

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Capital letter issue in the Term Base

Advanced search






Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
SDL Trados Studio 2021 Freelance
The leading translation software used by over 270,000 translators.

SDL Trados Studio 2021 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2021 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »



Forums
  • All of ProZ.com
  • Vyhledávání termínů
  • Zakázky
  • Fóra
  • Multiple search